OS4 DepotLogo by Liksmaskaren 
   Home     List Software     Search     Contact     Help  
   Bug tracker
   Locale browser


   Register here

 Main menu
   BBCode test
   ToDo List
   List Content
Support the site
 View comments
[View Software][View Issues][View Issue]
Title:Network browser based on WebKit core with GUI based on MUI.
Created:20110905 17:54 by orgin
 Issue details
Status:ClosedStatus Comment:was fixed in 1.23 or in newer mui
Title:System locks up when switching screens after download
Navigate: 1-4 
kas1ecan't reproduce20140106 16:58
Tried hard to reproduce it and can't.

Be sure you do tests without any 3d party apps which may behave badly. Like some switchers or docks.
ktaddPerhaps a timing related issue?20140112 21:07
I did some more experimenting

I dissabled all programs that run from workbench startup and still observed the same problem of total system lockup when switching screens with the screen to back gadget.

I then remembered that I was running my workbench screen in 1920x1080 16bit and Odessy in a 1920x1080 32 bit screen, so I switched my workbench to a 1920x1080 32bit screen. The problem thenbecame much less re-producable. I could usually switch back and forth between the screens several times before a lockup would occur. If I click on the screen to back buttons several time rapidly I could still get it to lock up. On occassion, even clicking it once would lock things but but it wasn't nearly as repeatable with the screens modes both set to 32but.

On a couple of occassions I didn't get it to lock up when switching screens but then when I clicked the Odyssey close window gadget it locked up.

Also note that I can use the Amiga-N or Amiga-M keys to switch screens as rapidly as possible and it never locks up.

I'm suspecting there is a timing related issue and it might not be an Odyssey issue but I have only had the problem in Odyssey and only after downloading a file.

I wonder if someone else with and X1000 could try reproducing the problem?
ktaddReliable way to re-produce found20140118 10:29
After some experimenting and input from other I have found a reliable way to re-produce this bug.
Turns out it's not specifically related to switching screens but is instead related to using the window boarder or screen gadgets.

Use the context menu to either copy the link or download the readme.
Then click on a window gadget and hold the left mouse button down and drag.
The system will lock up. Notice that part of the text from the link that was downloaded or copied appears highlighted under the mouse curser.

See this video: (<2M)
ktaddFixed in v1.2320140319 07:54
I'm unable to reproduce this defect in Odyssey v1.23. It seems to be fixed.
Feel free to close this issue. Thanks.
Navigate: 1-4 
Copyright (c) 2004-2024 by Björn Hagström. All Rights Reserved