OS4 DepotLogo by McFly 
   Home     List Software     Search     Contact     Help  
 Menu
 
 Features
   Crashlogs
   Bug tracker
   Locale browser
 
 Username

 Password


   Register here

 Main menu
   BBCode test
 
 Content
   Help
   ToDo List
   List Content
 
 
Support the site
 View comments
[View Software][View Issues][View Issue]
Name:easyuae
Title:EasyUAE - GUI for E-UAE 0.8.29+
Owner:Cyborg
URL:http://www.amigabounty.net/index.php?function=viewproject&projectid=40
Created:20100104 11:56 by orgin
 Issue details
Type:BugSeverity:Major
Status:NewStatus Comment:
Title:Fullscreen doesn't work
Version:0.8.29/1.4
Navigate: 1-5 
kas1eanswer20100131 22:44
@Saimo
Are you use GUI for making config file ? Why i ask, because for me all the games which i tested, works fine in the window and full-screen modes. Right now i also setup HDF with 3.1 + about 20 whdload games : and they all works fine in window and full-screen modes.
saimoRe: answer20100131 23:08
@kas1e

I used the GUI to generate the first file, then I customized it.
But this shouldn't matter, as the very same configuration works perfectly if I use amiga.screen_type=public - it's just that graphics don't show if I change that single line to amiga.screen_type=custom.
CyborgRe: answer20100202 11:38
@saimo

Can you please post your configuration here? I just tried and it works fine with screen_type=custom set via GUI here.

saimoRe: answer20100202 16:51
@Cyborg

Sure. I've just downloaded the new version, so I'll check first if it still happens.

EDIT

Unfortunately the problem has remained.
The configuration below can be tested with the game AQUANAUT (get it from Back to the Roots: http://team.back2roots.org/Games/Files/Aquanaut%2C2/), but please note that it happens with *everything*: games / applications / AOS 3.9); also note that the very same configuration works perfectly with E-UAE 0.8.29-WIP4.

config_description=AQUANAUT
config_hardware=false
config_host=false
config_version=0.8.29
amiga.rom_path=
amiga.floppy_path=
amiga.hardfile_path=
amiga.savestate_path=
amiga.cpu_idle=0
ppc.use_tbc=yes
amiga.screen_type=custom
amiga.publicscreen=
amiga.use_dither=false
amiga.use_grey=false
use_gui=yes
use_debugger=false
kickstart_rom_file=KS_3.1.rom
kickstart_ext_rom_file=
kickstart_key_file=
flash_file=
cart_file=
kickshifter=false
floppy0=RAM Disk:AQUANAUT/1.adf
floppy0type=0
floppy1=
floppy1type=-1
floppy2=
floppy2type=-1
floppy3=
floppy3type=-1
nr_floppies=0
floppy_speed=800
parallel_on_demand=false
serial_on_demand=false
serial_hardware_ctsrts=true
serial_direct=false
scsi=false
scsi_device=
sound_output=normal
sound_channels=stereo
sound_stereo_separation=7
sound_stereo_mixing_delay=0
sound_frequency=44100
sound_interpol=none
sound_adjust=0
sound_volume=0
sound_latency=100
joyport0=mouse
joyport1=kbd1
bsdsocket_emu=false
synchronize_clock=no
maprom=0x0
gfx_framerate=1
gfx_width=320
gfx_height=256
gfx_width_windowed=320
gfx_height_windowed=256
gfx_width_fullscreen=320
gfx_height_fullscreen=256
gfx_refreshrate=0
gfx_vsync=false
gfx_lores=true
gfx_linemode=none
gfx_correct_aspect=false
gfx_fullscreen_amiga=true
gfx_fullscreen_picasso=false
gfx_center_horizontal=smart
gfx_center_vertical=smart
gfx_colour_mode=8bit
immediate_blits=true
ntsc=false
hide_cursor=true
show_leds=false
keyboard_leds=numlock:none,capslock:none,scrolllock:none
chipset=aga
collision_level=none
fastmem_size=0
a3000mem_size=0
z3mem_size=0
bogomem_size=0
gfxcard_size=0
chipmem_size=4
cpu_speed=max
cpu_type=68020
cpu_compatible=false
cpu_cycle_exact=false
blitter_cycle_exact=false
log_illegal_mem=false
catweasel_io=0x0
kbd_lang=it
state_replay=no
state_replay_rate=250
state_replay_buffer=20971520
input.config=0
input.joymouse_speed_analog=20
input.joymouse_speed_digital=10
input.joymouse_deadzone=33
input.joystick_deadzone=33
input.mouse_speed=100
input.autofire=10
input.1.mouse.0.disabled=0
input.1.mouse.0.axis.0=MOUSE1_HORIZ.0
input.1.mouse.0.axis.1=MOUSE1_VERT.0
input.1.mouse.0.axis.2=MOUSE1_WHEEL.0
input.1.mouse.0.button.0=JOY1_FIRE_BUTTON.0
input.1.mouse.0.button.1=JOY1_2ND_BUTTON.0
input.1.mouse.0.button.2=JOY1_3RD_BUTTON.0
input.2.mouse.0.disabled=0
input.2.mouse.0.axis.0=MOUSE1_HORIZ.0
input.2.mouse.0.axis.1=MOUSE1_VERT.0
input.2.mouse.0.axis.2=MOUSE1_WHEEL.0
input.2.mouse.0.button.0=JOY1_FIRE_BUTTON.0
input.2.mouse.0.button.1=JOY1_2ND_BUTTON.0
input.2.mouse.0.button.2=JOY1_3RD_BUTTON.0
input.3.mouse.0.disabled=0
input.3.mouse.0.axis.0=MOUSE1_HORIZ.0
input.3.mouse.0.axis.1=MOUSE1_VERT.0
input.3.mouse.0.axis.2=MOUSE1_WHEEL.0
input.3.mouse.0.button.0=JOY1_FIRE_BUTTON.0
input.3.mouse.0.button.1=JOY1_2ND_BUTTON.0
input.3.mouse.0.button.2=JOY1_3RD_BUTTON.0
input.4.mouse.0.disabled=0
input.4.mouse.0.axis.0=MOUSE1_HORIZ.0
input.4.mouse.0.axis.1=MOUSE1_VERT.0
input.4.mouse.0.axis.2=MOUSE1_WHEEL.0
input.4.mouse.0.button.0=JOY1_FIRE_BUTTON.0
input.4.mouse.0.button.1=JOY1_2ND_BUTTON.0
input.4.mouse.0.button.2=JOY1_3RD_BUTTON.0

While I'm at it, here's an additional bug report I spotted while doing these last tests: the fullscreen height value saved by the GUI reflects the *width* (I guess it's just a matter of copy&paste not followed by a change of variable, that's why I'm not opening a new issue for it).
saimoRe: answer20100205 19:21
@Cyborg

I just found that the no-show problem happens only when the selected chipset is AGA.
Navigate: 1-5 
Copyright (c) 2004-2017 by Björn Hagström. All Rights Reserved
Amiga OS and its logos are registered trademarks of Hyperion Entertainment