OS4 DepotLogo by Angel 
   Home     List Software     Search     Contact     Help  
 Menu
 
 Features
   Crashlogs
   Bug tracker
   Locale browser
 
 Username

 Password


   Register here

 Main menu
   BBCode test
 
 Content
   Help
   ToDo List
   List Content
 
 
Support the site
 View comments
[View Software][View Issues][View Issue]
Name:owb pukapuka
Title:Origyn Web Browser, webkit, CSS capable
Owner:
URL:http://www.sand-labs.org/owb
Created:20080831 19:05 by orgin
 Issue details
Type:BugSeverity:Minor
Status:Closed FixedStatus Comment:Fixed in 3.15
Title:OWB redirected to WAP site
Version:<= 3.13 & 3.14...
Navigate: 1-4 
joergOWB redirected to WAP site20090611 01:35
I guess most of them check the user-agent and mistake the "ppc" in it for "PocketPC" :-(
Of course "ppc" is the PowerPC CPU family, and I even changed it already from "PPC" in older versions of OWB to "ppc" which fixed for example the broken redirections to the mobile versions on facebook.com and search.aol.com, but some sites seem to be even worse.

It's either the "ppc", or even much worse and they redirect all WebKit based browsers to their mobile sites just because for example the iPhone uses a WebKit based browser.

If you want to check what it actually is you can set the OWB_USER_AGENT environment variable to change the user-agent OWB uses. You have to quit and restart OWB after changing it. In OWB version 3.14 running on AmigaOS 4.1 the default is "Mozilla/5.0 (compatible; Origyn Web Browser; AmigaOS 4.1; ppc; U; en) AppleWebKit/531.0+ (KHTML, like Gecko, Safari/531.0+)".
If a site doesn't work with a different user-agent either it's broken JavaScript, for example only checking for IE and FireFox and treating everything else as mobile device.

In any case the sites are broken, mobile devices have additional headers the AmigaOS 4.x port of OWB of course doesn't have, for example the display size.
TSKThanks20090611 12:09
Thanks explaining this !
samo79WAP20090611 14:42
I have the same problem visiting:

http://www.microsoft.com
joergOWB redirected to WAP site20090613 01:51
I have the same problem visiting:

http://www.microsoft.com
I've added a workaround for the broken www.microsoft.com site, which seems to redirect browsers running on systems with PowerPC CPU to the mobile version, but I haven't found out what the bug on www.kauppalehti.fi is yet.
Navigate: 1-4 
Copyright (c) 2004-2024 by Björn Hagström. All Rights Reserved